分类 有线网络 下的文章

静音全万兆全固态nas(持续更新)

历时半年,终于把硬件凑齐了
硬件:主板 x11sdv-16c,内存 64g*2,散热 d15s,硬盘笼 516sp,硬盘 860evo-4t,网卡 x710-4t
硬件1

软件:待续
测试:待续

2018年10月目前最便宜的万兆nas华芸的as4004t

这段时间在升级虚拟化服务器,一个重要功能就是要升级群晖的ds3018xs,6盘万兆nas,升级的原因是x86的cpu性能比较弱功耗高,6盘噪音比较大,计划是4块三星860dct 3.84t,但是由于cpu散热一直没有解决就搁置了。偶然间看到台湾网友发的华芸的万兆nas,as4004t一下来了兴趣,armcpu,自带万兆网卡,小巧,看评测读能到600m,写能到300m,价格3500,买来试试。
下面是开箱
1箱子正面
全家福,电源是12v,90w
内容物
外壳是塑料
nas正面
背面是被吐槽最多的,太丑
nas背面
内部有铁架
nas内部
盘托和群晖一样是硬盘快拆,但是没有锁
盘托
希捷企业级充he的10t硬盘,新买的两块已经换成银河系列的彩标了
硬盘

之所以没上ssd一方面是因为cpu性能有限,不能发挥ssd潜力,重要原因是!穷!(一块860dct3.84t的ssd可以买这四块硬盘了)

初始化各家都差不多,联网下固件,配置管理员,配置硬盘raid等
我用的是raid5,目前还没有完成raid校验,写入有200m,读有600m左右,完成校验后应该会好一点,功率约50w,噪音比ds3018xs小很多,发热也小,符合我作长期开机存储的需求,偶尔可能后台下点电影什么的吧,至于群晖ds3018xs让它做冷备吧。
20181119更新
由于四块硬盘共振噪音比较大,趁双十一换了四块860evo 4tb,使用raid0,共计14.4tb,每周定时同步一次到我我的ds3018xs里,暂时解决了噪音和数据安全问题,但也不是长久之计。
20181224更新
四块860evo 4tb使用raid0,修改nas网卡、交换机、mac mini万兆网卡的mtu为9000后实际能达到台湾网友的测试结果,但是官方还是差不少。
ssdraid0mtu9000测试结果

官网介绍:https://www.asustor.com/product?p_id=57
官方性能说明(ssd raid5,读有1100m,写有600m)https://www.asustor.com/product/performance?p_id=57
台湾网友测评:https://garynil.tw/2018/10/1264/asustor-4004t/

cisco交换机与netgear交换机配置链路聚合

以思科WS-C3560X-24P和网件GS116Ev2为例,由于GS116Ev2只支持static lag,所以以下为trunk的静态链路聚合。trunk可以理解为传递vlan的链接。如果只是某个vlan的链路聚合的话修改trunk为access。
思科配置

ssh -oHostKeyAlgorithms=+ssh-dss -oKexAlgorithms=+diffie-hellman-group1-sha1 cisco@ip
Password: 
Core_Switch>enable
Password: 
Core_Switch#configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
Core_Switch(config)#interface Port-Channel 4
Core_Switch(config-if)#description To_GS116Ev2
Core_Switch(config-if)#switchport trunk encapsulation dot1q
Core_Switch(config-if)#switchport mode trunk
Core_Switch(config-if)#interface GigabitEthernet0/1
Core_Switch(config-if)#switchport trunk encapsulation dot1q
Core_Switch(config-if)#switchport mode trunk
Core_Switch(config-if)#channel-group 4 mode on
Core_Switch(config-if)#interface GigabitEthernet0/2
Core_Switch(config-if)#switchport trunk encapsulation dot1q
Core_Switch(config-if)#switchport mode trunk
Core_Switch(config-if)#channel-group 4 mode on
Core_Switch(config-if)#exit
Core_Switch(config)#exit
Core_Switch#

网件配置
1,选择需要聚合的端口,按图勾选配置,然后apply
网件1
2,启用聚合,如图,然后点击apply
网件2

至此,两台交换机配置完毕,连接两根网线,等待几分钟后完成。
思科交换机查看链路聚合状态方法

Core_Switch#show etherchannel summary 
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 4
Number of aggregators:           4

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)          -        Gi0/21(P)   Gi0/22(P)   
2      Po2(SU)          -        Gi0/19(P)   Gi0/20(P)   
3      Po3(SU)          -        Gi0/17(P)   Gi0/18(P)   
4      Po4(SD)          -        Gi0/11(D)   Gi0/12(D)   

网件由于是简单网管交换机,没有状态显示。需要注意的是网件启用lag的admin后需要等几分钟才会生效。

家用万兆网络的降级和升级(201807)

去年分享了我家的万兆网络拓扑 https://www.willnet.net/index.php/archives/88/
今年有降级有升级,如图
拓扑图
1.主要的降级是核心交换机从 netgear 的 m4300-24x 降级为 xs716t,降级原因功耗太高,并且噪音稍高,降级后功耗减少一半,噪音基本听不到了
2.其次降级的是路由器,由之前多个独立路由器切换到 esxi 上的 routeros,功耗降低,方便统一管理,esxi 上自建 dns,自建 ikev2,自建 ss,esxi 是研凌的 7200u+32g 内存,安装 esxi6.7
3.升级的是接入交换机,gs108tv2 更换成两个 gs110emx,两个 10g 电口,带 vlan 和链路聚合,功能满足需求
4.其次升级是无线,原来全套 cisco 更换成 unifi 的,两个 uap-ac-shd,一个 key 控制器
5.还有升级是联通家用 500m 更换成联通光快线,1 个固定公网 ip
6.其他变化还有,联通电视盒子撤了,经常影音不同步;加了一个 dnet 的专机;小米盒子国际版换成了 appletv ; nas 由 716+换成 ds3018xs+intel 的 x550 万兆网卡,局域网上传下载在 700m 左右; gen8 吃灰有几个月了;雷电 3 万兆网卡换成了 akitio 的 thunder3 network adapter,passive cooling,静音。

总体是朝着静音&全万兆升级。 ps:都是 rj45 电口,网线是超五类。

pps:xs716t 自带风扇有高频噪音,已更换猫扇A4x20 PWM,温度升高10度,但是噪音几乎没有了,日常功率约45w-50w,比m4300的90w降低近一半。
2018年9月更新,更换猫扇的xs716t截图
更换猫扇的xs716t截图

万兆电口交换机推荐

2017年12月能买到的万兆电口交换机对比推荐
推荐网件的xs716t,16口+2共享sfp+,噪音27db,价格7k,不在乎噪音可以上xs728t,24电口+4独立sfp+,噪音45db。15k左右。
再差一点就是gs110emx,8口千兆,2口万兆电口,简单网管,可配置链路聚,国行价格2.5k,gs110mx是不带管理的傻瓜交换机,跟华硕的XG-U2008类似,价格不到2k。